Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Fehlermeldung beim Eintragen
#1
Hallo,

Ich habe heute das MGB 0.6.2 lokal zum Testen nach der Wiki Anleitung installiert. Soweit hat auch alles funktioniert.

* Die Tabellen in der MySQL-Datenbank wurden vom Installtionsskript erfolgreich angelegt.
(mgb_captcha, mgb_entries, mgb_lastip, mgb_settings, mgb_user)
* Die Überprüfung der MGB Installtaion hat keine Fehlermeldungen ausgegeben - alles war grün.
* Der Inhalt der Datei config.inc.php sieht auch korrekt aus. ($mgb_installation_complete = TRUEZwinkern
* Die MGB Administration funktioniert bestens.

Jetzt wollte ich einen ersten Testeintrag in das lokal installierte Gästebuch vornehmen. Leider bekomme ich nach Eingabe sämtlicher erforderlicher Felder folgende Fehlermeldung:
(newentry.php, Line 158) Error: Field 'comment' doesn't have a default value

Ich habe folgende Konfiguration:
* Apache/2.2.11 (Win32) PHP/5.2.6
* MySQL Server Version: 5.0.67-community-nt
* MySQL-Client-Version: 5.0.51a
* PHP extension: mysql

Woran liegt's?

Greets,
Billy
Zitieren
#2
Hallo, die Fehlermeldung sagt es eigentlich schon aus. Das Feld "comment" in der Datenbank hat keinen Standardwert. Dies ist kein wirklicher Fehler, sondern lediglich ein Hinweis von PHP. Du kannst das umgehen indem Du mit PhpMyAdmin dem Feld einen Standardwert zuweist, oder die Ausgabe der Fehlermeldung umgehst indem Du in der newentry.php die Zeile
Code:
error_reporting(E_ALL & ~E_NOTICE);
auskommentierst. So:
Code:
//error_reporting(E_ALL & ~E_NOTICE);

Gespeichert wird der Eintrag aber, oder?
Zitieren
#3
@mopzz
Hallo mopzz,

danke für Deinen Tipp Großes Grinsen . Ich habe auf in lokal installierten Test-DB im Feld 'comment' den Standardwert auf "NULL" gesetzt.
Damit funktioniert es bestens. Der Eintrag wird korrekt gespeichert.

Greets,
Billy
Zitieren


Möglicherweise verwandte Themen…
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Keine Anzeige von Einträgen bei Sonderzeichen Maucki 5 6.847 15.07.2013, 18:12:38
Letzter Beitrag: mopzz
  Fehlermeldung bei der Installation des MGB 0.6.9.1 Bö1 5 11.177 20.06.2013, 00:09:32
Letzter Beitrag: gmollygreen
  Fehlermeldung Cat 3 5.282 21.05.2013, 21:08:32
Letzter Beitrag: mopzz
  Fehlermeldung Bock 3 5.789 25.02.2013, 19:26:33
Letzter Beitrag: mopzz
  fehlermeldung nach upgrade Bock 7 15.664 15.08.2012, 16:28:44
Letzter Beitrag: Salli
  Fehler beim Mailversend Aquablue71 11 10.581 22.07.2011, 10:46:55
Letzter Beitrag: sixtyseven
  Fehlermeldung nach Update auf 0.6.4 Fotowolle 21 16.627 05.11.2010, 17:46:07
Letzter Beitrag: Ben
  Hallo, Fehler beim Anmelden dnh24 0 3.292 10.03.2009, 12:25:03
Letzter Beitrag: dnh24
  Fehlermeldung in der Zeile 258 und 259 DSanchez 1 2.464 17.01.2009, 11:26:57
Letzter Beitrag: mopzz
  Zeitstempel in den Einträgen wolf 0 3.331 20.11.2008, 13:37:51
Letzter Beitrag: wolf

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste