Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
mgb-0.6 Problem NACH der Installation
#1
Hallo,

Mein Problem ist folgendes :

Die Installation hat Problemfrei Funktioniert aber als ich das GB dann Aufrufen wollte kam folgendes :

Warning: Cannot use a scalar value as an array in /home/www/cwcity/hosting/m/y/mystery/htdocs/GB/config.inc.php on line 7

Warning: Cannot use a scalar value as an array in /home/www/cwcity/hosting/m/y/mystery/htdocs/GB/config.inc.php on line 8

Warning: Cannot use a scalar value as an array in /home/www/cwcity/hosting/m/y/mystery/htdocs/GB/config.inc.php on line 9

Warning: Cannot use a scalar value as an array in /home/www/cwcity/hosting/m/y/mystery/htdocs/GB/config.inc.php on line 10

Warning: Cannot use a scalar value as an array in /home/www/cwcity/hosting/m/y/mystery/htdocs/GB/config.inc.php on line 11
(load_settings.php) Error: Access denied for user: 'ftpuser@localhost' (Using password: NO)

Woran kann das liegen? Am Webanbieter bei dem ich bin? Hab ich was falsch gemacht?

Hier noch der Link zum GB http://mystery.cwsurf.de/mgb/index.php

Hoffe ihr könnt mir helfen.

Gruß
Dirk
Zitieren
#2
Frage: Wurde Deine config.inc.php richtig angelegt? Hol sie mal vom Server und öffne sie. Denn laut Fehlermeldung kannst Du nicht auf die Datenbank zugreifen, was darauf zurückzuführen sein könnte, dass Du was falsch eingegeben hast.

Doch dieses "Warning: Cannot use a scalar value as an array in [...]" beunruhigt mich ein bisschen... Noch nie gehört. Muß ich mich selbst erst drüber schlau machen.
Zitieren
#3
register_globals: Aktiv <--- ist das schlimm wenn ich das nicht Deaktiviere?

Also die config.inc.php wurde korrekt geschrieben.
Zitieren
#4
mystery schrieb:register_globals: Aktiv <--- ist das schlimm wenn ich das nicht Deaktiviere?
Sollte normalerweise deaktiviert sein aus Sicherheitsgründen, das GB ist jedoch so programmiert dass es nicht schlimm ist, wenn es an bleibt.
mystery schrieb:Also die config.inc.php wurde korrekt geschrieben.
Diese Meldung
Code:
(load_settings.php) Error: Access denied for user: 'ftpuser@localhost' (Using password: NO)
sagt aber aus, dass irgendwas falsch eingegeben wurde. Benutzername oder Passwort. Ist aber auch komisch, denn in so einem Fall, lässt sich das GB gar nicht installieren.
Zitieren
#5
Code:
(load_settings.php) Error: Access denied for user: 'ftpuser@localhost' (Using password: NO)

Vorallem was hat ftpuser@localhost damit zu tun? FTP wurde doch nicht angefragt Oo

Und der Verweis gibt doch auch nicht die Config.inc.php an sondern eine load_settings.php <--- hat diese datei vielleicht damit zu tun???
Zitieren
#6
Code:
// load settings from database
        $sql = "SELECT * FROM ".$db['prefix']."settings";
        $link = @mysql_connect($db['hostname'], $db['username'], $db['password']) or die ("(load_settings.php) Error: ".mysql_error());
        @mysql_select_db($db['dbname'], $link) or die ("(load_settings.php) Error: ".mysql_error());
        $result = @mysql_query($sql, $link) or die ("(load_settings.php) Error: ".mysql_error());

    $settings = @mysql_fetch_array($result);

Hier mal ein auszug aus der load_settings.inc.php
In diesem auszug steht auch schon Error hat es damit irgendwas auf sich???
Zitieren
#7
mystery schrieb:Vorallem was hat ftpuser@localhost damit zu tun? FTP wurde doch nicht angefragt Oo
"ftpuser@localhost" stellt einen Verbindungsversuch dar. Dabei ist "ftpuser" der Benutzername den Du anscheinend eingegeben hast. Anders kann ich mir das nicht erklären.
mystery schrieb:Und der Verweis gibt doch auch nicht die Config.inc.php an sondern eine load_settings.php <--- hat diese datei vielleicht damit zu tun???
Aber "Warning: Cannot use a scalar value as an array in /home/www/cwcity/hosting/m/y/mystery/htdocs/GB/config.inc.php on line 7" verweist auf die config.inc.php...
mystery schrieb:In diesem auszug steht auch schon Error hat es damit irgendwas auf sich???
Nein... da drin steht "Error:" weil dies dann als Fehlermeldung ausgegeben wird, wenn sich dort ein Fehler ereignet... Nämlich dieser:
Code:
(load_settings.php) Error: Access denied for user: 'ftpuser@localhost' (Using password: NO)

Irgendwas musst Du falsch eingegeben haben, denn sonst würde es funktionieren. Welche PHP und welche MySQL Version benutzt Du? Bei welchem Serveranbieter bist Du?
Zitieren
#8
Der Webhoster ist http://www.cwsurf.de
Dort Arbeite ich mit PHP 5 und MySQL 5.
Zitieren


Möglicherweise verwandte Themen…
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Gästebuch Admin Passwort vergessen, Problem mit der Zusendun Armin8572 1 3.966 27.08.2013, 11:55:37
Letzter Beitrag: mopzz
  Fehlermeldung bei der Installation des MGB 0.6.9.1 Bö1 5 12.036 20.06.2013, 00:09:32
Letzter Beitrag: gmollygreen
  Akismet Installation? Ruhrpottjung 2 4.616 18.06.2013, 05:46:26
Letzter Beitrag: mopzz
  fehlermeldung nach upgrade Bock 7 16.835 15.08.2012, 16:28:44
Letzter Beitrag: Salli
  nach update noch Meldungen im admin-Bereich Manni 0 8.333 09.07.2012, 21:56:34
Letzter Beitrag: Manni
  Riesen Problem... MissJazzy 3 6.318 27.05.2012, 07:05:12
Letzter Beitrag: mopzz
  Keine Smilies mehr sichtbar nach Upgrade pack fabian86 2 4.964 15.01.2012, 11:35:15
Letzter Beitrag: fabian86
  2 Fehler bei der Installation Taharkas 1 4.040 03.11.2011, 16:24:33
Letzter Beitrag: mopzz
  Fehler nach erfolgreicher Installation Siebenwinde 1 4.124 27.10.2011, 13:15:37
Letzter Beitrag: Siebenwinde
  SQL-Fehler bei der Installation mattis 1 3.495 02.07.2011, 15:32:01
Letzter Beitrag: mopzz

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste