Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
[GELÖST] Keine Installation möglich
#1
Hallo,

Ich bin noch blutiger Anfänger. Trotzdem möchte ich ein MGB-Gästebuch erstellen.

Soweit auch kein Problem. Nur bei der Installation wird mir gesagt, daß mein "My SQL" veraltet ist, was aber nicht der Fall sein kann. Kann die Installation nicht fortsetzen. Kann mir vielleicht jemand sagen, was und in welcher PHP-Datei ich ändern muß, damit ich die Installation trotzdem fortsetzen kann.

Ich hoffe die Frage ist nicht zu blöd, habe aber im Forum nichts darüber gefunden.

Danke im Voraus, Swampy

PS.: Bin bei <!-- m --><a class="postlink" href="http://www.bplaced.net">http://www.bplaced.net</a><!-- m -->
Zitieren
#2
Was genau für eine Meldung wird denn angezeigt? Welche MySQL Version etc.
Zitieren
#3
Die Meldung vor der Installation:

PHP Version: 5.3.2 OK
MySQL Version: MySQL Native Driver NOT OK
GD Bibliothek: Ja OK
Konfig schreibbar: Ja OK

register_globals: Inaktiv OK
- Deine MySQL Version ist älter als die erforderliche. Eine Aktualisierung wird empfohlen.

Die Version von MySQL bei meinem Webhoster: MySQL 5.0.88

Mit MGB 0.5.4.8 funktioniert die Installation übrigens!

Gruß, Swampy
Zitieren
#4
Brauchst Du noch mehr und wenn ja, welche Informationen, oder ist es einfach nicht möglich, bei mir MGB 6.x zu benutzen?

Gruß, Swampy
Zitieren
#5
Ich habe mich ein bisschen schlau gemacht über diesen MySQL Native Driver. So wie ich das verstanden habe, ist das keine gewöhnliche MySQL Datenbank, sondern eine PHP-interne Datenbank die MySQL emuliert. So hab' ich es jedenfalls verstanden. Deshalb wird das von der Installation wohl nicht erkannt.

Probier mal folgendes:

Öffne die "install.php" im Ordner "install" des MGB 0.6.3 und suche
Code:
                switch(version_compare('3.23', mysql_get_client_info())) {
                    case -1: $img_mysql = "<img src=\"template/images/ok.png\" alt=\"OK\">";
                        break;
                    case 0: $img_mysql = "<img src=\"template/images/ok.png\" alt=\"OK\">";
                        break;
                    case 1: $img_mysql = "<img src=\"template/images/nok.png\" alt=\"NOT OK\">";
                        $error_mysql = 1;
                        break;
                    }

Ersetze dann
Code:
$error_mysql = 1;
durch
Code:
//$error_mysql = 1;

Somit dürfte die Warnung übersprungen und die Installation fortgesetzt werden. Mal schauen ob es dann klappt.
Zitieren
#6
Vielen Dank für die Mühe,

Hat alles wunderbar funktioniert! Großes Grinsen

Mein Gästebuch: http://schwarzweiss.bplaced.net/gb.php
Über einen Besuch würde ich mich freuen!
Zitieren


Möglicherweise verwandte Themen…
Thema Verfasser Antworten Ansichten Letzter Beitrag
  mbg-latest speichert keine Texte mit Sonderzeichen JMC 1 4.018 28.08.2013, 18:55:09
Letzter Beitrag: mopzz
  Keine Anzeige von Einträgen bei Sonderzeichen Maucki 5 7.329 15.07.2013, 18:12:38
Letzter Beitrag: mopzz
  Fehlermeldung bei der Installation des MGB 0.6.9.1 Bö1 5 11.656 20.06.2013, 00:09:32
Letzter Beitrag: gmollygreen
  Akismet Installation? Ruhrpottjung 2 4.419 18.06.2013, 05:46:26
Letzter Beitrag: mopzz
  Permanente Begrüßung vom Moderator möglich? Oldnovice 3 5.041 14.05.2013, 19:56:44
Letzter Beitrag: mopzz
  install nicht möglich Warning: fopen(../includes/config.inc. Punk12 1 4.806 02.06.2012, 05:55:35
Letzter Beitrag: mopzz
  Keine Smilies mehr sichtbar nach Upgrade pack fabian86 2 4.750 15.01.2012, 11:35:15
Letzter Beitrag: fabian86
  Direktes Upgrade von 0.6.6 auf 0.6.9 möglich? chris_m 1 4.145 01.01.2012, 16:22:58
Letzter Beitrag: mopzz
  2 Fehler bei der Installation Taharkas 1 3.879 03.11.2011, 16:24:33
Letzter Beitrag: mopzz
  Fehler nach erfolgreicher Installation Siebenwinde 1 3.955 27.10.2011, 13:15:37
Letzter Beitrag: Siebenwinde

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste